
‭ ‬

‭Release Notes for ADAPT-Builder‬

‭Version 23.0.0 Enhancements/Corrections‬
‭Design/Analysis:‬

‭●‬ ‭Added ACI 318-2019 (22)  design code.‬
‭●‬ ‭Added torsional design for beams and one-way slabs per ACI 318-19/22.‬

‭○‬ ‭Added detailed calculation reports for torsional design per ACI 318-19/22.‬
‭○‬ ‭Added detailed calculation reports for one-way shear design per ACI 318 -14, 19 and 22.‬

‭●‬ ‭Added the calculation of mass participation factors for vibration analysis.‬
‭●‬ ‭Added Exact Integration Method for column code check.‬
‭●‬ ‭Added an input for the Parme Beta Factor for PCA Contour Method for column code check.‬
‭●‬ ‭Enhanced Column Design report to include RISA column design loads.‬
‭●‬ ‭Added an option to disregard the DropCap/Panel in the flexural design which provides more flexibility‬

‭in modeling and design.‬
‭●‬ ‭Enhanced the calculation of effective depth used in evaluation of one-way shear strength to consider‬

‭all steel in tension zone, including tendons and base reinforcement.‬
‭●‬ ‭Enhanced tendon discretization at tendon ends for improved accuracy.‬
‭●‬ ‭Enhanced wall meshing for adjacent walls with varying offsets.‬
‭●‬ ‭Enhanced the placement of rebar within a beam, with the center of gravity measured from the beam‬

‭bottom/top.‬
‭General:‬

‭●‬ ‭Improved tendon modeling within beam by referencing the CGS from the top/bottom fiber of the‬
‭combined section.‬

‭●‬ ‭Added a handle to the Control Point CGS text for spline and fillet tendons.‬
‭●‬ ‭Added the End text options that allows the user to move the tendon end text and clean the drawings.‬
‭●‬ ‭Improved the export of rebar to DWG by creating additional layers, facilitating effortless modification‬

‭of rebar properties and text in CAD software.‬
‭●‬ ‭Enhanced the DXF Calibration function to automatically display Message bar upon activation,‬

‭improving usability.‬
‭●‬ ‭Enhanced the Instability warning message with the link to the relevant Help topic to assist users in‬

‭troubleshooting the model.‬
‭●‬ ‭Enhanced the Design Section RTF reports to only print selected design sections.‬

‭Interface/Graphics:‬
‭●‬ ‭Added unified rebar display settings for on-screen viewing, printing, and export to DWG ensuring‬

‭consistency in the visual representation.‬
‭●‬ ‭Enhanced the Tendon and Rebar Display Settings by moving to Properties grid in order to provide‬

‭more options to customize the display.‬
‭●‬ ‭Enhanced the auto-orientation of tendon end text for better clarity of tendon plans.‬
‭●‬ ‭Added Block object to the Properties Grid.‬
‭●‬ ‭Improved the automatic update of the Visibility Grid.‬
‭●‬ ‭Added the Linework category to the Visibility Grid, streamlining visibility control for non-structural‬
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‭elements.‬
‭●‬ ‭Implemented buttons in the Floor Design ribbon to easily adjust the font size for design section‬

‭results, enhancing user control and customization.‬
‭●‬ ‭Added Default Visibility button to the Visibility grid for convenient retrieval of default views.‬
‭●‬ ‭Added column Label to the Column Detailed report.‬
‭●‬ ‭Enhanced MAT mode to automatically open on the lowest plane.‬

‭Corrections:‬
‭Design:‬

‭●‬ ‭Corrected an issue where the Wall Design Manager gave an error when the number of curtains for‬
‭zone bars was set to one.‬

‭●‬ ‭Corrected an issue with the Wall Designer closed abruptly when the default material was removed‬
‭from the model.‬

‭●‬ ‭Corrected an issue where, in certain cases, the spacing of shear rebar caused division by zero and‬
‭resulted in an error message.‬

‭●‬ ‭Corrected the rebar criteria used for beam design by assigning the criteria per design section instead‬
‭of support line.‬

‭●‬ ‭Implemented correction in Eurocode EC2, setting ultimate strain limits to 0.05 for reinforcing steel‬
‭and 0.0315 for prestressing steel.‬

‭●‬ ‭Corrected an issue with the Eurocode EC2 that in certain cases caused decreased section capacities‬
‭or an elevated demand for additional mild steel.‬

‭●‬ ‭Corrected an issue where the excluding tendons and rebar beyond the beam flange width from‬
‭design was not considered correctly.‬

‭●‬ ‭Corrected an issue with the moment capacity of a beam when a design section is generated at the‬
‭intersection of two beam segments.‬

‭●‬ ‭Corrected an error in the calculation of area Acf for As,min, which, in certain cases, resulted in overly‬
‭conservative minimum reinforcement for non-prismatic sections of two-way prestressed slabs at‬
‭support locations.‬

‭●‬ ‭Corrected an issue where the balance loading calculation was inaccurate in cases where the support‬
‭line span included only a beam without slab.‬

‭●‬ ‭Corrected a FEM node assignment to a region for the calculation of balance loading, leading to more‬
‭accurate results.‬

‭●‬ ‭Corrected an issue with the calculation of rhow used in the equations for one-way shear strength‬
‭capacity per ACI code.‬

‭●‬ ‭Corrected an issue with the calculation of As,min for the upturned beams with unbonded tendons for‬
‭ACI code.‬

‭●‬ ‭Corrected an issue where the shear reduction factor was not initialized correctly for ACI 14 code.‬
‭●‬ ‭Corrected the moment of inertia for T-sections with effective flange width.‬
‭●‬ ‭Corrected the issue where in some cases the wrong Mu was used in the calculation of the ratio‬

‭Vu*dp/Mu, for one-way shear strength per ACI code.‬
‭●‬ ‭Corrected an issue where the user could not change the cover for wall design.‬

‭Analysis‬
‭●‬ ‭Corrected an issue with pattern loads not being combined correctly in load combinations.‬
‭●‬ ‭Corrected an issue with combination results for the nested long-term load combinations.‬

‭Operations:‬
‭●‬ ‭Corrected the Properties Grid to facilitate the input of variable patch loads.‬
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‭●‬ ‭Tendon Display Manager - Tendon Shape does not display when selected.‬
‭●‬ ‭Corrected an issue where the Visibility grid failed to update following the execution of Clear Mesh‬

‭and the utilization of tools within the Analysis Visibility panel.‬
‭●‬ ‭Corrected an issue where the program deleted the solution after closing the Load Combination‬

‭dialog even if no editing was done.‬
‭●‬ ‭Corrected an issue where the Idealized Section Integrity check incorrectly reported the status.‬
‭●‬ ‭Corrected an issue where the program was closing abruptly when double-clicking on the support line‬

‭without a design solution.‬
‭General:‬

‭●‬ ‭Corrected an issue with tendon profile discontinuity at beams.‬
‭●‬ ‭Corrected the Hint Mode display information for tendons.‬
‭●‬ ‭Corrected an issue where the Column Section Types were not allowing the Column Code Check to‬

‭run.‬
‭●‬ ‭Corrected the values reported in the Applied Loads RTF report for Sds and Sd1when using ASCE‬

‭7-16 in the Seismic Load Wizard.‬

‭Version 22.0.3 Enhancements/Corrections‬
‭Licensing:‬

‭●‬ ‭Converted to cloud-based subscription licensing.‬

‭Version 22.0.2 Enhancements/Corrections‬
‭Enhancements:‬

‭●‬ ‭Added wall design per ACI 318-19 code.‬
‭●‬ ‭Improved the Wall Design Manager to only consider strength combinations.‬
‭●‬ ‭Added option to automatically update wall section reinforcement when designing walls.‬
‭●‬ ‭Implemented a new Feedback button that allows the user to request improvements to the software.‬

‭Corrections:‬
‭●‬ ‭Corrected an issue where the Wall Design Manager showed the multiple selection indicator (dashed‬

‭lines) for reinforcement when only one wall section was selected.‬
‭●‬ ‭Improved wall design sections to include more complicated pier shapes during section generation.‬
‭●‬ ‭Corrected an issue with the consideration of load case solutions in the Wall Design Manager.‬
‭●‬ ‭Corrected an issue where the Wall Design Manager included all load combinations in the design of‬

‭walls instead of the user selected combinations.‬

‭Version 22.0.1 Enhancements/Corrections‬
‭Enhancements:‬

‭●‬ ‭Added an Integrated Column Design Engine.‬
‭○‬ ‭Added a Column Code Check feature to perform a check of code compliance for columns‬

‭and their reinforcement for ACI 318-14 and ACI 318-19 codes.‬
‭○‬ ‭Provided a Column Detailed report in XLS file format including a printable Summary page,‬

‭interaction diagrams, detailed column properties, detailed column loads, and code check‬
‭results.‬

‭○‬ ‭Added new graphical reporting options for viewing Column Code Check results.‬
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‭○‬ ‭Added intuitive design settings that gives  the user flexibility in the evaluation of columns.‬
‭●‬ ‭Added a Display Wall Sections tool to toggle wall design section visibility.‬
‭●‬ ‭Improved Define Pier Label to auto name pier labels when a new pier label is added.‬
‭●‬ ‭Included utilization results in the Column Design XLS report.‬
‭●‬ ‭Added a Section Type Editor to the Column Design ribbon for faster and bulk editing of Column‬

‭Section Type properties.‬
‭●‬ ‭Enhanced the Property Grid to include options to auto assign section types to columns.‬
‭●‬ ‭Enhanced the Colorize Grid to include the ability to colorize columns by horizontal and/or vertical‬

‭reinforcement and Rho.‬
‭Corrections:‬
‭Design:‬

‭●‬ ‭Corrected an issue where Punching Shear results were incorrect when the extend to slab edge option‬
‭was selected.‬

‭●‬ ‭Corrected the One-Way Shear capacity for models with high axial tension force.‬
‭●‬ ‭Corrected an issue when calculating the moment of inertia of a T-Section when using the effective‬

‭flange width.‬
‭Operations:‬

‭●‬ ‭Corrected an issue where adding spans to tendons using the Smart Tools was causing the program‬
‭to close unexpectedly.‬

‭●‬ ‭Corrected an issue to allow users to change the Group for tendons using the Properties Grid.‬
‭General:‬

‭●‬ ‭Corrected the Seismic Load Wizard to calculate the k coefficient using the correct equations when‬
‭the ASCE 7-16 code is selected.‬

‭●‬ ‭Included a warning message when a user enters a PDELTA load combination which includes the‬
‭Hyperstatic load case.‬

‭Integration:‬
‭●‬ ‭Corrected an issue with importing loads from RISA where not all load cases were being labeled‬

‭correctly upon import.‬

‭Version 22.0.0 Enhancements/Corrections‬
‭Enhancements:‬

‭●‬ ‭Added a new Support Line Span Optimizer for faster more efficient optimization of tendons within a‬
‭support line span.‬

‭○‬ ‭Includes an Optimization Diagram which shows the allowable range of tendon force for Top‬
‭and Bottom Stresses, Precompression and Balanced Loading.‬

‭○‬ ‭Optimized design sections follow the controlling sections within the support line span. Users‬
‭also have the ability to choose the design sections within a span to use for optimization.‬

‭○‬ ‭Users can choose the criteria to optimize by (stress, precompression, balanced loading).‬
‭○‬ ‭Apply changes to tendons of your choice.‬
‭○‬ ‭Update the service solution to see the effect of the changes to the FEM solution.‬

‭●‬ ‭Added a new Update Service Solution feature.‬
‭○‬ ‭Improves iterative tendon design workflow.‬
‭○‬ ‭Performs a combined/truncated analysis and design where only the tendon information is‬

‭updated in the solution, and no preprocessing is required.‬
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‭○‬ ‭Service combinations to be updated can be chosen by the user.‬
‭●‬ ‭Added the ability to model tendons within ramps.‬

‭○‬ ‭Tendons can be modeled in both the slab and ramp where the two overlap.‬
‭○‬ ‭Tendons can now be modeled in the beams connected to ramps, including beams that slope‬

‭with the ramp.‬
‭○‬ ‭Tendons are discretized and accounted for properly in the analysis.‬

‭●‬ ‭Allowed the modeling of drop cap and drop panels at the same column for use in Punching Shear‬
‭design.‬

‭●‬ ‭Enhanced Punching Shear design to account for both a drop cap and drop panel modeled at the‬
‭same column.‬

‭●‬ ‭Added a calculation report that shows the calculation of minimum reinforcement with equations and‬
‭code references.‬

‭●‬ ‭Added ASCE 7-16 option for generation of wind loads using the Wind Load Generator.‬
‭●‬ ‭Added ASCE 7-16 option for generation of seismic loads using the Seismic Load Generator.‬
‭●‬ ‭Enhanced the load combination generator to include manually created load cases in ASCE 7‬

‭combinations when load case format is correct.‬
‭●‬ ‭Enhanced the load combination generator to include load cases generated by the wind and seismic‬

‭load wizards to general ACI lateral combinations.‬
‭●‬ ‭A new restraints category has been added to the Visibility Grid.‬

‭Corrections:‬
‭Analysis:‬

‭●‬ ‭Corrected an issue where beams, not fully covered by a slab region, may not be discretized into‬
‭frame elements properly.‬

‭Design:‬
‭●‬ ‭Corrected an issue where unnecessary shear reinforcement was being added beyond drop panels.‬
‭●‬ ‭Corrected the Wood Armer method to report only for two-way design sections.‬
‭●‬ ‭Corrected an issue in the calculation of shear capacity, per ACI 318-19 Table 22.5.5.1, when Av = 0.‬
‭●‬ ‭Corrected an issue where sqrt(f'c) was capped incorrectly, per ACI 318-19 Section 22.6.5.5, for‬

‭punching shear design.‬
‭●‬ ‭Corrected an issue where incorrect design section results were reported at wall locations due to‬

‭post-tensioning.‬
‭Operations:‬

‭●‬ ‭Corrected an issue where a modification to one load magnitude changes all load magnitudes for the‬
‭selected load.‬

‭●‬ ‭Corrected an issue where the program was saving models upon closing the model without‬
‭prompting the user.‬

‭●‬ ‭Corrected several issues with Importing of Line Loads using XLS import.‬
‭●‬ ‭Corrected an issue with the initialization of wall boundaries.‬
‭●‬ ‭Corrected an issue with the assignment of wall boundaries for walls imported from INP or‬

‭transformed from a DWG/DXF file.‬
‭●‬ ‭Improved the Visibility panel to update after generating the Calculated Rebar plan.‬
‭●‬ ‭Improved save command when working with files located on the network to verify the new/current‬

‭model is in the network folder before deleting the original model.‬
‭General:‬

‭●‬ ‭Corrected an issue where the Long-term Deflection Settings were not showing up in RC mode.‬



‭Release Notes‬

‭●‬ ‭Corrected an issue where legacy models were causing the program to close unexpectedly.‬
‭●‬ ‭Improved the speed of opening models.‬
‭●‬ ‭Corrected a spelling error in the Wall Length Error message.‬
‭●‬ ‭Corrected an issue where some models created in ADAPT-Builder 2019 or earlier could not be‬

‭opened.‬
‭●‬ ‭Removed the legacy Scroll Bar Settings from General Settings.‬
‭●‬ ‭Updated the text in the Boundary Condition tab of the column or wall properties for the current user‬

‭interface.‬
‭●‬ ‭Corrected an issue where Usage Case reactions were deleted when closing and reopening a model.‬

‭Reporting/Graphical Results:‬
‭●‬ ‭Corrected an issue causing wall pier reactions to not be reported graphically.‬
‭●‬ ‭Corrected an issue where the z-translation and ss-Translation results for wall translation were‬

‭switched in the Results View browser.‬
‭●‬ ‭Corrected an issue with the reporting of the number of shear stirrups displayed through the Results‬

‭View Panel.‬
‭●‬ ‭Fixed a spelling mistake in the List of Contents report.‬

‭Version 21.0.1 Enhancements/Corrections‬
‭Enhancements:‬
‭Integration:‬

‭●‬ ‭Added a link with RISA-3D to import superstructure reactions to the podium level in ADAPT-Builder.‬
‭This feature  includes:‬

‭○‬ ‭Preview of point and line reactions to be imported.‬
‭○‬ ‭Option to choose which load cases to import.‬
‭○‬ ‭Option to map load cases to existing load cases in ADAPT-Builder.‬

‭Performance:‬
‭●‬ ‭Enhanced Analysis speed to up to 40% faster Analysis for some models.‬
‭●‬ ‭Enhanced Data Loading up to 70% faster data loading for Support Line, Design Section dialog.‬
‭●‬ ‭Faster overall performance for models with spline tendons.‬

‭Design:‬
‭●‬ ‭Implemented minimum rail length requirements as per ACI 318-2014, Sec. 18.14.5.1, and ACI‬

‭318-2019, Sec. 18.14.5.3.‬
‭●‬ ‭Added an option to define maximum demand-capacity ratio for flexural design.‬

‭Operations:‬
‭●‬ ‭Added an option to colorize loads for easy visualization of load cases,  loads and their magnitudes.‬

‭It includes:‬
‭○‬ ‭Patch load colorization based on the load case name and magnitude in each direction.‬
‭○‬ ‭Patch load intensity maps based on a total load applied in a location for an individual load‬

‭case.‬
‭○‬ ‭Line load colorization based on the load case name and magnitude in each direction.‬
‭○‬ ‭Point load colorization based on the load case name and magnitude in each direction.‬

‭●‬ ‭Added a Point Loads XLS report with location and magnitude of loads which can be modified and‬
‭re-imported into ADAPT-Builder.‬

‭●‬ ‭Added Change Ramp Orientation tool for easy modification of a ramp’s slope orientation.‬
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‭●‬ ‭Added Save as Default option in the Visibility Grid to allow for convenient saving of preferred views‬
‭set by the user.‬

‭●‬ ‭Added an option to save docked locations of the Property Grid, Visibility Grid and Colorize Grid.‬
‭●‬ ‭Added option to open the Help File with F1.‬
‭●‬ ‭Enhanced the Import from XLS option to select which load cases to import.‬

‭General:‬
‭●‬ ‭Added Appearance section in the Property Grid.‬
‭●‬ ‭Added message when viewing deflections for load combinations that include hyperstatic loads.‬
‭●‬ ‭Enhanced the generation of the default tributary region for a Support Line.‬
‭●‬ ‭Enhanced the scaling of point, line and patch loads to prevent out of view scaling.‬
‭●‬ ‭Enhanced workflow with models stored in network locations to allow for maximum performance‬

‭benefits by making a local copy of the model, upon exit the model is saved back to the network‬
‭location.‬

‭Corrections:‬
‭Integration:‬

‭●‬ ‭Corrected an issue with user defined Usage Case Results not transferring to S-Concrete.‬
‭Operations:‬

‭●‬ ‭Corrected an issue with the base reinforcement being modified when generating the calculated rebar‬
‭plan.‬

‭●‬ ‭Corrected an issue with resetting of non-user defined labels.‬
‭●‬ ‭Corrected a graphical issue with the resetting of all labels.‬
‭●‬ ‭Corrected an issue to allow the input of user defined gridlines.‬
‭●‬ ‭Corrected an issue where user defined load combinations were deleted when using the Load‬

‭Combination Generator.‬
‭●‬ ‭Corrected an issue where design sections were not generated when the support line was modeled‬

‭slightly outside of the slab.‬
‭●‬ ‭Corrected an issue where the Dynamic Support Line Editor was not recognizing perpendicular walls‬

‭or beams as a support.‬
‭●‬ ‭Corrected an issue with the Tendon Optimizer closed unexpectedly when trying to view user defined‬

‭load combinations.‬
‭●‬ ‭Corrected an issue where the model closed unexpectedly when copying elements in plane with zero‬

‭offset.‬
‭●‬ ‭Corrected an issue where Generating New Tributaries causes some models to close unexpectedly.‬
‭●‬ ‭Corrected an issue where the program closed unexpectedly when copying support lines from one‬

‭model to another.‬
‭●‬ ‭Corrected an issue where the program closed unexpectedly when using a non-solid pattern to fill the‬

‭area of a component.‬
‭●‬ ‭Corrected an issue where DWG export was not working in some cases due to the naming of the‬

‭component’s layers.‬
‭●‬ ‭Corrected an issue where the deletion of a tendon control point causes a kink in the tendon profile.‬

‭General:‬
‭●‬ ‭Removed the option in General Settings to automatically open an item’s property dialog.‬
‭●‬ ‭Corrected an issue with ramp reactions when analyzing building loads in Multi-Level mode.‬
‭●‬ ‭Removed Wall Boundaries automatically being assigned at creation of walls.‬
‭●‬ ‭Corrected a graphical issue with the Visibility Grid not synchronizing with the Load Case displayed‬
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‭on the screen.‬
‭●‬ ‭Corrected an issue with the Tendon Optimizer Load Combination setting.‬
‭●‬ ‭Corrected an issue with the Tendon Auto Swerve Point settings resetting when opening the model.‬
‭●‬ ‭Corrected an issue with the default number of rails per side when working in a model created in‬

‭version 2019 or earlier.‬
‭●‬ ‭Corrected an issue where the component material property changed when adding multiple structural‬

‭components at a time.‬
‭●‬ ‭Corrected an issue where the Load Takedown/ Lateral Reaction Load Case Solution Selection would‬

‭reset after each Analysis run.‬
‭●‬ ‭Corrected an issue when trying to assign the Tributary Detection Tolerance of multiple Support Lines‬

‭at a time using the Property Grid.‬
‭●‬ ‭Corrected an issue where the Visibility Panel did not turn on and off the slab regions.‬
‭●‬ ‭Corrected an issue in the Property Grid where the user-entered value for the number of stirrup legs‬

‭was applied only to the support line that was drawn first.‬
‭●‬ ‭Corrected an issue where the deflection contour was not generated in some cases.‬
‭●‬ ‭Corrected an issue where load magnitudes were being reset to zero when a Load Case change was‬

‭made to multiple loads at a time in the Properties Grid.‬
‭●‬ ‭Corrected an issue where the bar description was not shown along the created reinforcement.‬
‭●‬ ‭Corrected the description of the Fz magnitude in the Property Grid.‬
‭●‬ ‭Corrected a graphical issue with wall and column display.‬
‭●‬ ‭Corrected an issue where the Support Lines were not properly updated if modified as a group using‬

‭the Property Grid.‬
‭Analysis:‬

‭●‬ ‭Corrected an issue where the Live Load Reductions # of Supported Levels option was not‬
‭recognizing all the levels above.‬

‭●‬ ‭Corrected an issue where Single Level Analysis ignored components for ramps when not defined on‬
‭the active plane.‬

‭●‬ ‭Corrected an issue where load combinations weren’t recognizing referenced load combinations‬
‭generated by the LC Generator, including wind loads.‬

‭Design:‬
‭●‬ ‭Corrected an issue where designing walls gives an error when the option to check boundary‬

‭elements is selected.‬
‭●‬ ‭Corrected an issue in NBR code where no results were given when trying to design Manual Design‬

‭Sections.‬
‭●‬ ‭Corrected the punching shear geometry detection for columns located at the slab edge.‬
‭●‬ ‭Corrected the punching shear total rail quantity displayed graphically and in XLS Punching Shear‬

‭Report.‬
‭Reporting/Graphical Results:‬

‭●‬ ‭Corrected a graphical issue with the Punching Shear Reinforcement Plan.‬
‭●‬ ‭Added a column to show stirrup size for each column individually in the XLS Punching Shear Report.‬
‭●‬ ‭Corrected an issue where the stud rail size wasn’t updating in the XLS Punching Shear Report.‬

‭Licensing:‬
‭●‬ ‭Correct an issue where version 21.0 of the program shows as version 20.0 in the Licensing‬

‭Dashboard.‬
‭●‬ ‭Corrected the message displayed when the license expired.‬
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‭●‬ ‭Network License Commute Utility was added to the program installer.‬

‭Version 21.0.0 Enhancements/Corrections‬
‭General:‬

‭●‬ ‭Added the Tendon Smart Tools which aids in dynamically modeling tendons and allows rapid‬
‭modification of a single tendon or groups of tendons. It includes:‬

‭○‬ ‭Wizard type modeling with auto-recognition for the location of high points, short spans,‬
‭openings, and slab edges.‬

‭○‬ ‭Mapping of distributed tendons between boundary tendons can be accomplished quickly‬
‭using max spacing, fixed spacing, and number of tendon options.‬

‭○‬ ‭Assignment and modification of the tendon span shape in plan view for a single tendon or‬
‭multiple tendons using a two-click selection line.‬

‭○‬ ‭Editing of tendon points - add, delete, move and align high points or swerve points for a‬
‭single tendon or a group of tendons at the same time.‬

‭○‬ ‭Option to “cut” tendons using the Cut to region tool.‬
‭○‬ ‭Option to check precompression, number of tendons, number of strands, and tendon spacing‬

‭along the selection line.‬
‭○‬ ‭Option to assign tendon Direction as distributed, or banded.‬
‭○‬ ‭Option to check for “short” tendons and colorize them for easy identification.‬

‭●‬ ‭Added LC Generator for auto-generation of load combinations based on selected design code.‬
‭●‬ ‭Added Visibility panel with improved view controls:‬

‭○‬ ‭Dynamic list of components which shows only components that exist in the model.‬
‭○‬ ‭The components are listed in categories, which are groups of similar components across the‬

‭model.‬
‭○‬ ‭Visibility is controlled based on component or category level.‬
‭○‬ ‭Option to control the visibility of top and bottom columns or walls separately.‬
‭○‬ ‭Option to display tendons per direction (distributed, banded).‬
‭○‬ ‭Improved display of loads by displaying per load case instead of load type.‬
‭○‬ ‭Improved visibility control for rebar.‬
‭○‬ ‭Enhanced workflow for quicker display of the components versus the Select/set View Items‬

‭dialog.‬
‭●‬ ‭Enhanced Long-term load combination generation:‬

‭○‬ ‭Added modeling of loading history.‬
‭○‬ ‭Auto-calculation of long term combination factors based on concrete model, age at loading‬

‭and observation day.‬
‭●‬ ‭Enhanced Map Banded tendons option:‬

‭○‬ ‭Added option to map tendons for total dead load, self weight and superimposed dead load.‬
‭○‬ ‭Added Trim tolerance option where tendons are auto extended/trimmed to slab edge if in the‬

‭tolerance range.‬
‭○‬ ‭Added condition for assignment of cantilever shapes to end spans.‬
‭○‬ ‭Extended the list of available shapes for mapping of tendon mid spans.‬

‭●‬ ‭Added Help menu with a library of all ADAPT resources.‬
‭○‬ ‭Web based HTML help file (best viewed with Chrome)‬
‭○‬ ‭Link to program documentation‬
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‭○‬ ‭Link to Technical Notes‬
‭○‬ ‭Link to training and program usage videos‬

‭●‬ ‭Added Direction (bonded, distributed) parameter for tendons in the Property Grid.‬
‭●‬ ‭Added an option to assign standard rebar shapes to banded and distributed bars for Australian code.‬
‭●‬ ‭Added an option to colorize columns and walls by offsets to the Colorize panel.‬
‭●‬ ‭Added Skip Loading Subregion to the Property Grid.‬
‭●‬ ‭Updated the saving of project templates to include the latest criteria options in the program.‬
‭●‬ ‭Corrected an issue with the display of governing load combination in the Support Line dialog.‬
‭●‬ ‭Corrected an issue where manual design sections were initiated with the wrong value for the Stirrup‬

‭legs parameter in the Property Grid.‬
‭●‬ ‭Corrected an issue with the wrong level assignment for components copied to another level.‬
‭●‬ ‭Corrected a graphical issue when in some cases the program created additional point springs.‬
‭●‬ ‭Corrected an issue with the display of Cracking Moment as the governing load combination in the‬

‭Support Line dialog.‬
‭●‬ ‭Corrected typo in the description for the Design Criteria panel of the Criteria Ribbon.‬
‭●‬ ‭Corrected the list of parameters for Punching shear in the Property Grid to exclude Precompression‬

‭entry if the program is opened in RC mode.‬
‭●‬ ‭Disabled the Reference Plane assignment in the Property Grid when in creation mode.‬

‭Operations:‬
‭●‬ ‭Corrected an issue where the number of tendons was not calculated correctly when Map Banded‬

‭was used for the support line that includes a beam.‬
‭●‬ ‭Corrected an issue where the program closed unexpectedly when selecting columns corrupted by‬

‭the deletion of the reference plane.‬
‭●‬ ‭Corrected an issue where the program closed unexpectedly when using the Exclude Meshing tool‬

‭and trying to analyze.‬
‭●‬ ‭Resolved an issue where the program closed unexpectedly when using the Add Text tool in the‬

‭Home ribbon.‬
‭●‬ ‭Resolved an issue where the program closed unexpectedly when using Model->Transform tools to‬

‭transform polygons with 0 width dimension.‬
‭●‬ ‭Corrected an issue where the program prompted an error message when columns of different sizes‬

‭were selected and modified in the Property Grid.‬
‭●‬ ‭Resolved an issue where the program closed unexpectedly during Load Takedown calculation due to‬

‭incorrect modeling of overlapping slabs.‬
‭Analysis:‬

‭●‬ ‭Corrected an Issue where the upper and lower wall nodes were not shifted to the same location if‬
‭not concentrically modeled.‬

‭Design:‬
‭●‬ ‭Added option to limit stud spacing to 3d/4, as per ACI-318 Table 8.7.7.1.2.‬
‭●‬ ‭Added Australian - AS3600 (2018) design code.‬
‭●‬ ‭Corrected an issue where the Tendon Optimizer was reporting incorrect stresses for the estimated‬

‭stress block in the form of a non-numerical value.‬
‭●‬ ‭Corrected an issue where overlapping tendons were only accounting for one of the overlapped‬

‭tendons during section design.‬
‭Reporting/Graphical Results:‬

‭●‬ ‭Corrected the total tendon length for spline tendons in the Tendon Totals report.‬
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‭●‬ ‭Corrected an issue with color-coding of design sections for one way shear stress check.‬
‭●‬ ‭Corrected an issue where the graphical punching shear stress ratio report in some models displayed‬

‭skewed wall design sections.‬
‭Integration:‬

‭●‬ ‭Corrected the sign for the axial force when exported to S-CONCRETE.‬
‭●‬ ‭Corrected an issue with the export of local forces for slanted columns to S-CONCRETE.‬
‭●‬ ‭Resolved an issue where space at the end of a level name was causing the export to REVIT to fail.‬
‭●‬ ‭Corrected an issue with import of distributed bar extents from the INP file.‬
‭●‬ ‭Resolved an issue where DWG Export resulted in the corrupt DWG file when Punching Shear‬

‭Reinforcement Plan was displayed.‬
‭Licensing:‬

‭●‬ ‭Added Borrow License option to allow you to use the subscription license offline.‬

‭Version 20.0.1 Enhancements/Corrections‬
‭General:‬

‭●‬ ‭Added an option to colorize tendons by span shape to the Colorize panel.‬
‭●‬ ‭Added the option to Save As Version 2019 in the File menu.‬
‭●‬ ‭Added the End Stressing option in the Properties Grid for tendons with effective force.‬
‭●‬ ‭Updated the “instability warning” message to reference the options in the current user interface.‬
‭●‬ ‭Improved interface to give an option to disable the Design Section tools in Multi-Level Mode.‬
‭●‬ ‭Modified the Item Properties dialog to be inactive in Creation Mode.‬
‭●‬ ‭Corrected a typo with the IBC version number associated with the ACI 318-19 code.‬
‭●‬ ‭Corrected build release date in Help-->About Builder dialog window.‬
‭●‬ ‭Corrected an issue with the display of SI units in the Dynamic Tendon Optimizer-->Calcs tab.‬

‭Operations:‬
‭●‬ ‭Enhanced the AutoSave feature to allow users to set the number of backup files.‬
‭●‬ ‭Enhanced efficiency for editing of column type selection.‬
‭●‬ ‭Improved the Colorize panel to enable the user to easily identify columns with the same rectangular‬

‭shape.‬
‭●‬ ‭Enhanced the Properties Grid to automatically update as changes are made to the selected items.‬
‭●‬ ‭Enhanced the Properties Grid to not allow entry of component dimensions less than specified in the‬

‭initialization file.‬
‭●‬ ‭Enhanced the Properties Grid to allow data entry in Creation Mode.‬
‭●‬ ‭Correlated the Node Shifting options between the Properties Grid and the Item Properties window.‬
‭●‬ ‭Correlated the behavior of components offset(s) between the Properties Grid and the Item‬

‭Properties window.‬
‭●‬ ‭Corrected an issue where only the first rebar entity within a selection set was being modified when‬

‭changed in the Properties Grid.‬
‭●‬ ‭Corrected an issue where selecting Rebar using Select by Type would not allow a change from‬

‭Calculated to Base Reinforcement in the Properties Grid.‬
‭●‬ ‭Corrected an issue in Properties Grid where rebar cover remained locked after Type was changed‬

‭from Calculated to Base.‬
‭●‬ ‭Fixed an issue where the correct Section Type would not appear in the Properties Grid after it was‬

‭assigned in Type Manager.‬
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‭●‬ ‭Fixed an issue where the beam dimensions were displayed incorrectly in the Properties Grid when‬
‭assigned a Section Type.‬

‭●‬ ‭Corrected an issue where the program would close unexpectedly if the user selected a Tributary‬
‭Region and Support Line together.‬

‭●‬ ‭Corrected an issue where newly created reinforcement was missing the description.‬
‭●‬ ‭Corrected an issue where a Design Code modification resulted in duplicate Load Combination‬

‭names.‬
‭●‬ ‭Corrected an issue where walls were being generated with the Node Shift option set to Manual.‬
‭●‬ ‭Resolved an issue where the program shut down when opening a new model within the program.‬
‭●‬ ‭Resolved an issue with the input of modulus of rupture for non ACI codes.‬

‭Performance:‬
‭●‬ ‭Improved performance of Design algorithm.‬

‭Analysis:‬
‭●‬ ‭Corrected an issue where Spline Tendons were flagged during analysis as “outside the slab region”‬

‭when swerved around openings or slab edges.‬
‭●‬ ‭Corrected an issue where Temperature results were incorrect due to triangular shell elements.‬
‭●‬ ‭Corrected an issue where renaming of concrete material in single level mode caused unexpected‬

‭closing of the program during analysis.‬
‭Design:‬

‭●‬ ‭Resolved an issue where the Cm value for column design was being conservatively passed to the‬
‭SCO file as 1.0.‬

‭●‬ ‭Resolved an issue to prevent the program from unexpectedly closing, in some cases, during design‬
‭with pattern loads present.‬

‭●‬ ‭Corrected criteria for when an opening is considered as slab edge in Punching Shear Check.‬
‭●‬ ‭Corrected an issue where calculated moment capacity using the Wood Armer method was‬

‭conservative when selectively analyzing load combinations.‬
‭●‬ ‭Updated the formula for calculation of effective moment of inertia for EuroCode (EC2).‬

‭Reporting/Graphical Results:‬
‭●‬ ‭Modified the program to display the diameter for studs and bar size for stirrups, in the display of‬

‭Punching Shear Reinforcement.‬
‭●‬ ‭Enhanced the program to display only the applicable menu items within the Generate Compiled‬

‭Report menu.‬
‭●‬ ‭Resolved an issue where the program was generating reinforcement of zero length.‬
‭●‬ ‭Resolved an issue where in some cases the Design Section Forces and Design Section Rebar reports‬

‭were empty.‬
‭●‬ ‭Resolved a discrepancy between the graphical results legend and the diagram results in some‬

‭models.‬
‭●‬ ‭Resolved an issue in the Design Section coloring for the One-Way Shear stress check.‬

‭Integration:‬
‭●‬ ‭Corrected an issue with the Export->Revit function to create a compatible file for import to recent‬

‭Revit versions.‬
‭●‬ ‭Corrected an issue where the Input Method for distributed rebar was not set correctly after being‬

‭imported from the INP file.‬
‭Licensing:‬

‭●‬ ‭Added license type in Help->About Builder dialog.‬
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‭●‬ ‭Resolved an issue where users with perpetual licenses were incorrectly being prompted to sign-in to‬
‭subscription licensing.‬

‭Version 20.0 Enhancements/Corrections‬
‭Analysis:‬

‭●‬ ‭A new option was added to user-define the value for rupture modulus for cracked deflection checks‬
‭and reinforcement necessary to meet or exceed cracking moment.‬

‭●‬ ‭Stiffness modifiers for beams were made to be consistent between Modify Selection and Property‬
‭Grid for the M22 modifier.‬

‭Modeling:‬
‭●‬ ‭New and improved functionality for the automatic creation of middle strips and allocation of‬

‭tributary (%) to column strips was added in the Dynamic Support Line Editor from Floor‬
‭Design>Dynamic Editor>Middle Strips and Limits.‬

‭●‬ ‭General improvements were made to the Dynamic Support Line Editor from Floor Design>Dynamic‬
‭Editor. These include:‬

‭○‬ ‭Creation of unique support lines per span‬
‭○‬ ‭Auto-adjust to snap perpendicular for support lines created from the Wizard‬
‭○‬ ‭Auto-trim and extend of support lines to slab edges‬
‭○‬ ‭Color coding for support line limits for NONE, Max Width, and % allocation for column strips.‬

‭●‬ ‭An improvement was made for modeling of spline tendons that were graphically shown with a kink‬
‭complicating tendon selection.‬

‭●‬ ‭An improvement was made to Floor Design>Delete Design Strips to erase designs section from‬
‭support lines when this option is selected.‬

‭●‬ ‭An improvement was made to Loading>Load Combinations to retain load combinations defaulted to‬
‭or user-defined when the design code is changed from Criteria>Design Codes.‬

‭Performance:‬
‭●‬ ‭A performance enhancement was made to loading of contour results in Result Display Settings‬

‭graphical display.‬
‭●‬ ‭Licensing has been modified to support RISA cloud, network, and standalone licensing.‬
‭●‬ ‭The program now includes operability for licensing and usage of FELT 3D w/Modeler for unbonded‬

‭tendon systems.‬
‭●‬ ‭A performance improvement was made to utilize multicore functionality and threading in Builder's‬

‭frame solver.‬
‭●‬ ‭Compatibility for 32-bit systems was removed.‬

‭Design:‬
‭●‬ ‭ACI 318-19 was implemented as a concrete design code.‬
‭●‬ ‭Punching Shear - An improvement was made for ACI code models for handling openings at or near‬

‭columns in reduction of critical sections and critical area. New options are given in Floor‬
‭Design-Shear Options.‬

‭●‬ ‭Punching Shear: A new feature was added to allow the end-user to define what critical section sides‬
‭participate in the punching shear check within the Property Grid.‬

‭●‬ ‭Punching Shear: An improvement was made to the handling of columns, when rotated, to the‬
‭effective depth when a critical section passes through slabs of different thickness.‬

‭●‬ ‭An improvement was made to the default value and use of the unsupported wall height for wall‬
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‭section design.‬
‭●‬ ‭Wall Designer was modified to properly write loads and other parameters to S-Concrete when using‬

‭this tool for wall section design.‬
‭Reporting/Results:‬

‭●‬ ‭Print preview for all graphical reports was improved to display the correct next page in sequence.‬
‭●‬ ‭Punching Shear: The XLS result file was improved to properly report combined stress for punching‬

‭shear results.‬
‭●‬ ‭Punching Shear: A graphical improvement was made to the view of reinforcement for punching‬

‭shear to report if any supports exceed code allowable maximum shear capacity.‬
‭●‬ ‭Punching Shear: A graphical improvement was made to the view of stress ratios for punching shear.‬

‭If a single strength combo is selected, the program now reports the layer (critical section) that‬
‭produces the worst-case ratio in ( ). If the strength envelope is selected, the program reports the‬
‭combination that produces the worst case ratio in ( ).‬

‭●‬ ‭Punching Shear: A graphical improvement was made to the view of Condition at a column to report‬
‭the effective depth for the first critical section at a distance from the face of the column based on‬
‭code requirements.‬

‭●‬ ‭One-Way Shear: A graphical improvement to color code one-way shear requirements (NA, Reinforce,‬
‭Exceeds Code) for beams and one-way slabs.‬

‭●‬ ‭One-Way Shear: A graphical reporting improvement has been included in Result Display Settings to‬
‭report One-Way Shear results.(Item 7325) Results included are:‬

‭○‬ ‭Shear Stress Check - color coding of design sections‬
‭○‬ ‭Concrete Shear Strength, Phi,Vc‬
‭○‬ ‭Demand/Capacity ratio - Vu/Phi,Vc‬
‭○‬ ‭Required Reinforcement (Area of steel)‬
‭○‬ ‭Provided Reinforcement (Area of steel)‬
‭○‬ ‭Reinforcement layout‬

‭●‬ ‭A new feature has been added to graphically check differences, based on %, between physical and‬
‭idealized design section geometric properties of area and moment of inertia.‬

‭●‬ ‭Report Compiler: An improvement was made to the default graphical design strip report displayed in‬
‭the incorrect color.‬

‭●‬ ‭Report Compiler: An improvement was made to properly capture coloring of design strip results‬
‭when images are screenshot and used in the compiled report.‬

‭●‬ ‭Report Compiler: An improvement was made to screenshots showing Moment Capacity with‬
‭Demand in the compiled report caused the PDF creation to stall.‬

‭●‬ ‭Report Compiler: The graphical stress check reported in the compiled report was improved to‬
‭properly show colors as presented graphically on screen.‬

‭●‬ ‭Report Compiler: Screenshots taken and used in the compiled report were improved to properly‬
‭display shading as presented graphically on screen.‬

‭●‬ ‭Report Compiler: An improvement was made to the graphical reporting output that showed contours‬
‭underlaid when other results were selected to be shown.‬

‭●‬ ‭Report Compiler: Print Preview Zoom and Navigation were stabilized and made functional in all use‬
‭instances.‬

‭●‬ ‭An improvement was made to design section details to report both Physical and Idealized‬
‭properties.‬

‭●‬ ‭An enhancement was made to the detailed geometric properties of design sections to display the‬
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‭physical and effective properties of design sections when the effective flange option is used for‬
‭beams.‬

‭●‬ ‭An improvement was made for reporting of punching shear stresses for design code AUS3600 to‬
‭report separate allowable stresses for each bending direction.‬

‭Graphic/UI:‬
‭●‬ ‭Punching Shear: An improvement was made to make local design and analysis input for individual‬

‭columns as compared to global settings within the Property Grid.‬
‭●‬ ‭One-Way Shear: A modification was made to the Property Grid to include an entry for number of legs‬

‭when One-Way Shear criteria is selected for support lines and manual design sections.‬
‭●‬ ‭A new dockable Property Grid has been added for controlling component and other modeling object‬

‭properties, geometric assignments, design parameters, etc. This adds to current functionality of Item‬
‭Properties and Modify Selection.‬

‭●‬ ‭A new dockable Colorize dialogue window has been added to filter, sort, and colorize components‬
‭(slabs, columns, walls, openings, ramps, beams, drops), supports, springs, support lines, splitters,‬
‭etc. Colorized selections can be isolated for propagation of changes in Property Grid.‬

‭●‬ ‭A selectable option has been added to easily display component local axes in Property Grid.‬
‭●‬ ‭Report Compiler: A new Report Settings tool has been added to predefine report settings prior to‬

‭report compilation.‬
‭●‬ ‭The Items Properties dialogue was restored to properly open when using the option from the Modify‬

‭Ribbon.‬
‭●‬ ‭The Property Grid now includes the ability to change the tendon material for a group of selected‬

‭tendons. This is not available from Modify>Modify Selection.‬
‭Integration‬

‭●‬ ‭Inconsistencies in rebar data written to the ID assignment was out of sequence when rebar is‬
‭included in the INP file.‬

‭●‬ ‭Loads defined in Revit are now written to the INP file format for import to Builder.‬

‭Version 2019.2 Enhancements/Corrections‬
‭Analysis‬

‭●‬ ‭The option to "Reduce Axial Only" from Loading>LLR was also reducing moments on columns. An‬
‭improvement was made to apply this option only to axial loads when selected.‬

‭●‬ ‭A correction was made to ramp property modifications that were not recognized in writing input data‬
‭for the current analysis run.‬

‭●‬ ‭A correction was made to tributary load takedown where the original wall location was being‬
‭considered after the wall was moved.‬

‭●‬ ‭Ramp meshing was improved for different column and beam placement conditions.‬
‭●‬ ‭An improvement was made to wall mesh subdivision for long walls for better node commonality with‬

‭slab elements.‬
‭●‬ ‭A general meshing version compatibility resolution was made where models meshed in older version‬

‭v2017 were not able to be meshed in the v2019.‬
‭Modeling‬

‭●‬ ‭A new line hinge tool was added for modeling of internal hinges. The option is included when‬
‭modeling of a line support from Model>Supports>Line Support.‬

‭●‬ ‭Total Force input option, as compared to per strand, was added to the "Stressing" tab in the Tendon‬
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‭properties dialog window. When using this option, the program auto-scales the number of strands in‬
‭the "General" tab.‬

‭●‬ ‭A correction was made to tendons outside of the slab were being falsely flagged as modeling‬
‭integrity checks prior to meshing.‬

‭Design‬
‭●‬ ‭An improvement was made to the presence of openings when design sections cut through them‬

‭resulting in incorrect design section depths and reinforcement and PT depths in the section.‬
‭●‬ ‭Improvements were made to idealized design section geometry when cut over the slab and beam.‬
‭●‬ ‭Improvements were made to how the Wood Armer Method is implemented for twisting moments‬

‭(Mxy) in two-way slabs. The calculation of Mxy was improved to include integration over the section‬
‭cut line based on stress values. The program now reports Mxy in Design Section Actions when Wood‬
‭Armer is enabled from Criteria>Analysis/Design Options.‬

‭●‬ ‭An improvement was made for punching shear to not check the least critical section‬
‭(octagonal-shaped) outside of the shear reinforced zone when the first section at d/2 from face of‬
‭support passed allowable stress and did not require reinforcement.‬

‭●‬ ‭An improvement was made to the punching shear check when the seismic drift option is enabled‬
‭from the Floor Design>Shear Design. When checking critical sections outside of the shear-reinforced‬
‭zone (octagonal-shaped sections) the program was using the section critical area for determining‬
‭reinforcement necessary to meet the drift requirement. This resulted in increasing reinforcement‬
‭moving away from the support face. The critical section to be used for all locations within 4*h from‬
‭column face is the first critical section area at d/2 from the support face.‬

‭Reporting/Results‬
‭●‬ ‭Print preview for selected and all graphical reports from Reports>Open Compiled Reports>File was‬

‭enhanced for improved navigation and zoom in/out.‬
‭●‬ ‭Print preview for all graphical reports now displays the correct next page in sequence.‬
‭●‬ ‭A program stall was corrected when selecting Reports>Open Compiled Reports>File>Print Preview‬

‭all Graphical Reports and all graphical reports were selected in the selection tree.‬
‭●‬ ‭The pier reaction dialogue window from Reports>Wall>XLS Reports>Pier Reactions was improved to‬

‭indicate the pier local axes, reference axis and rotation direction.‬
‭●‬ ‭Punching shear reinforcement spacing output was made to be the same when shown graphically as‬

‭compared to the tabular report from Reports>Punching Shear>Punching Shear reinforcement.‬
‭Graphics/UI‬

‭●‬ ‭The spelling of "Tendon" was corrected in the INP file for Builder 2019.0 and latest INP versions‬
‭selectable from File>Export and INP selectable from File>Import.‬

‭●‬ ‭A correction was made to scaling of graphical loads based on the size setting in Visibility>View‬
‭Settings.‬

‭●‬ ‭The display of the unit system in Result Display Settings>Settings>Result Unit System was‬
‭corrected.‬

‭●‬ ‭An improvement was made where Home>Select by Type was causing the program to close‬
‭unexpectedly when the element selected and keyword did not produce a selected object.‬

‭●‬ ‭RISA branding and contact information updates were made to the splash screen and HELP dialogue‬
‭boxes.‬

‭Version 2019.1 Enhancements/Corrections‬
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‭Analysis‬
‭●‬ ‭A correction was made for the sign of distributed values for bending moment on a manual design‬

‭section not being consistent with the sign for the integrated value.‬
‭●‬ ‭An issue was resolved patch loads were not being discretized properly leading to absence of‬

‭modeled load in the analysis.‬
‭●‬ ‭An improvement was made to persistence of line load discretization when applied at the slab edges.‬

‭In rare cases, line loads were not discretized to nodes leading to absence of modeled load in the‬
‭analysis.‬

‭●‬ ‭An improvement was made to meshing of beams when negative offsets were assigned to the beam.‬
‭●‬ ‭An issue was resolved where zero uplift for a partial cantilever tendon shape in the Tendon‬

‭Properties dialogue window reported uplift. Tendon uplift - partial cantilever has no uplift and should‬
‭be zero.‬

‭Modeling‬
‭●‬ ‭New tools were added to the Shop Drawing Editor from the tendon toolbar. These include:‬

‭○‬ ‭Adding‬‭Chairs: Displays chairs and/or support types for tendons and accompanying support‬
‭bar size, spacing and extension settings.‬

‭○‬ ‭Edit Bars: Gives options to edit support type, support bar size and support bar extension.‬
‭○‬ ‭Anchors: Displays set anchor type for unbonded and bonded tendons.‬

‭●‬ ‭A correction was made in the Tendon Editor where CGS values were set back to default when the‬
‭option for end-span shape was used.‬

‭●‬ ‭An improvement was made in the Tendon properties dialogue to return a message when the green‬
‭checkmark is selected if the system type is set to Bonded and the Calculated Long-Term loss setting‬
‭is enabled. Long-term loss calculations are limited to unbonded tendons. Bonded tendons require‬
‭the use of lump-sum loss estimate input.‬

‭●‬ ‭An issue was corrected to model crashing when tendons that had become corrupted were selected‬
‭or clicked on.‬

‭●‬ ‭An issue was resolved that was related to program crashing when the Cantilever Partial tendon‬
‭shape was set in the Tendon Properties dialogue.‬

‭Performance‬
‭●‬ ‭Improvements were made to the performance and speed of data loading when levels are switched‬

‭with the Level Selector or Arrow Up and Down.‬
‭Design‬

‭●‬ ‭The load combination selection list in Wall Design Manager was improved to properly update the‬
‭load case selection based on the load combinations selected and available solution sources.‬

‭●‬ ‭A correction was made to the large required area of steel for two-way reinforcement for NBR and‬
‭EC2 design codes.‬

‭●‬ ‭An issue was resolved where manual design section values for axial and in-plane shear were‬
‭reported as zero and with incorrect max/min values on the cut line (bracketed values). Only the‬
‭integrated values are now reported.‬

‭●‬ ‭An improvement was made to the generation of the idealized sections produced in Designer for‬
‭section design.‬

‭●‬ ‭An improvement was made to retain design section types already assigned when stiffness modifiers‬
‭were assigned to those columns.‬

‭●‬ ‭An improvement was made to ignore the area of mesh reinforcement in design sections that cut‬
‭through openings.‬
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‭Reporting/Results‬
‭●‬ ‭An improvement was made related to crack widths being reported as zero and graphical results not‬

‭being produced. This stemmed from non-converging equilibrium state due to incorrect consideration‬
‭of prestressing force for prestressed sections.‬

‭●‬ ‭An issue was resolved where actions and reinforcement were reported as zero in tabular reporting‬
‭for manual design sections.‬

‭●‬ ‭The sign convention for axial force for design sections, both automatic and manual, was changed to‬
‭be consistent with general sign convention adoption in the program. Axial tension is positive and‬
‭axial compression is negative.‬

‭●‬ ‭An improvement was made to the graphical display of beam stirrups in the strip elevation view.‬
‭●‬ ‭An issue was resolved related to screenshots added to the report compiler not being deleted‬

‭properly from the Report Compiler dialogue.‬
‭Graphics/UI‬

‭●‬ ‭The FEM options for Consider and Disregard were added as right-click options.‬
‭●‬ ‭A licensing bug was fixed where the option for Lump-sum loss estimate was grayed out if the 3D Felt‬

‭option in the program splash screen was not selected.‬
‭●‬ ‭Ramp coloring was added to Visibility>Color Palette.‬
‭●‬ ‭Ramps are now shaded when the model is set to shaded view from Visibility>Shading.‬
‭●‬ ‭An issue was resolved where the program crashed if window selection was used to select an entity‬

‭to add vertices.‬
‭●‬ ‭An improvement was made to the visibility of soil bearing pressure contour lines that were skewed‬

‭back to the origin.‬
‭Integration‬

‭●‬ ‭ADAPT-Revit Link 2020 was released for compatibility with Autodesk Revit 2020.‬
‭●‬ ‭An improvement was made to the .INP file data when P-Delta combinations are included in a model.‬

‭An issue existed where regular service combinations were not being solved.‬
‭●‬ ‭An issue was resolved where tendons set to "Fillet-Radius" were not discretized properly when‬

‭written to the .INP file format from FILE>Export.‬
‭●‬ ‭The .INP file format was improved to allow offsets at both ends of a beam component.‬
‭●‬ ‭The .INP file format was improved to accept ramp data allowing ramps to be exchanged within‬

‭ADAPT-Builder using the .INP import/export options.‬

‭Version 2019.0 Enhancements/Corrections‬
‭Analysis‬

‭●‬ ‭The program now includes the option to run 2nd-order analysis for geometric nonlinearity (“big”‬
‭P-delta) based on the compilation of the elastic and geometric stiffness matrices. A new‬
‭analysis/design option type for P-delta is included in which combinations can be singularly run for‬
‭2nd order effects or processed as a batch based on a combination used to obtain the geometric‬
‭matrix. Graphical analysis results similar to regular combinations can be obtained for P-delta‬
‭combinations. These results can be utilized for the design of columns.‬

‭●‬ ‭The default value for the shrinkage load case was changed to 5.0x10E-4 in/in.‬
‭●‬ ‭An issue was resolved where some models with load patterns were crashing the .ADM file.‬

‭Modeling‬
‭●‬ ‭A new feature has been added to model ramps in the program. Ramps are limited to analysis only‬
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‭and cannot be designed through means of design strips. Tendons cannot be modeled in ramps.‬
‭Longitudinal and transverse beams can be modeled at ramps with options to automatically offset‬
‭the beams as well as offset walls and columns supporting ramps. Ramps are required to be‬
‭modeled in the same plane and the program constrains the graphical input as 3-point input to‬
‭enforce planar modeling.‬

‭●‬ ‭Design Strip Modeling: A new and improved Strip Modeling Dynamic Editor includes tools used to‬
‭more rapidly model and modify support lines and design strips. These include:‬

‭○‬ ‭Support Line Wizard: Creates a support based on a construction line defined by snap points‬
‭along the strip path.‬

‭○‬ ‭Support Line Limits: Changes selected support line design criteria and tributary limits for the‬
‭design strip.‬

‭○‬ ‭Wall: Allows the user to set constraints for how walls are considered for design strip‬
‭generation.‬

‭○‬ ‭Display: Sets the support line display for Direction, Criteria and Width Limit‬
‭●‬ ‭The program includes new and improved splitter functionality. The use of splitters has been‬

‭simplified to creating a boundary that the tributary edge extends when the width is required to be‬
‭limited to either side. Splitters are no longer required for any other purpose as the program has been‬
‭improved to recognize support line nodes at any location and properly generate strips.‬

‭●‬ ‭A new Shop Drawing Editor has been added and contains the following features:‬
‭○‬ ‭Tools: Converts all tendons to a new fillet-radius display type as compared to straight or‬

‭spline and allows for removal of all non-auto swerve points on tendons.‬
‭○‬ ‭Chair Groups: Allows the user to input on-demand chair bar maximum spacing and chair bar‬

‭extensions for graphical output of tendon support bars.‬
‭○‬ ‭Colors: Designates user-defined colors used to group like tendons by length.‬

‭●‬ ‭A new tendon representation option is available called 'Fillet.' In this mode the user enters a radius‬
‭for construction circles used to develop the in-plane curvature and shape of the tendon. The‬
‭Dynamic Tendon Editor controls the display of the construction circles from Mode-Show Fillet‬
‭Details.‬

‭●‬ ‭An issue was fixed related to the undo function after a tendon is deleted. The program now properly‬
‭restores the tendon object when undoing the delete.‬

‭●‬ ‭For full compatibility of use of the new Dynamic Strip Wizard options, the auto-creation of middle‬
‭strips when in RC mode had to be removed from Criteria-Analysis/Design Options. Users can use the‬
‭new features for more rapid creation and modification of both column and middle strips.‬

‭●‬ ‭Two offset inputs are given now for beams, slabs, support lines, tendons, ramps. This input is found‬
‭in the component property dialog under the 'Location' tab.‬

‭●‬ ‭An improvement was made to walls and columns having a blank material assignment when created‬
‭through a new project template file.‬

‭Design‬
‭●‬ ‭The program now includes the option to calculate the effective flange and properties of beams when‬

‭a support line is set to 'Beam' criteria. The design of the beam sections is performed using the‬
‭effective properties. The component of stress related to the precompression uses the full tributary‬
‭area of the section as does the graphical precompression result. ACI and EC2 calculations for‬
‭effective width are supported.‬

‭●‬ ‭When the PT Shop Drawing module is enabled, the program gives new input and functionality for the‬
‭calculation of long-term losses for unbonded tendons and bonded tendons stressed at the same‬
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‭time.‬
‭●‬ ‭New improvements have been made for punching shear according to ACI318-14. These include:‬

‭○‬ ‭The option to consider critical sections outside the shear reinforced zone with either a‬
‭rectilinear or octagonal-shaped critical section. ACI 318-14 Sections 22.6.4.2, 22.6.6.1‬

‭○‬ ‭The option to apply two-way shear provisions for minimum reinforcement for seismic drift.‬
‭ACI 318-14 Sections 18.14.5.1.‬

‭○‬ ‭Application of minimum two-way shear reinforcement at critical sections is based on the‬
‭requirement at the first section d/2 from face of support.‬

‭●‬ ‭An issue related to crashing when a section type is assigned to columns or beams was resolved.‬
‭●‬ ‭An issue was resolved related to the calculation of LL reduction factors of columns when you have‬

‭multiple overlapping loads.‬
‭●‬ ‭An improvement was made to update the current value for precompression when the tributary width‬

‭is changed in Settings and the span is re-optimized.‬
‭●‬ ‭A correction was made to the ‘a’ factor required for the CSA code when the effective depth, d, used‬

‭for two-way shear calculations exceeds 300mm. Per Section A23.3-14 and 13.3.4.3 the correct‬
‭factor is taken as 1300/(1000+d). Previously the program was using 1300/(1300+d). Canadian‬
‭Punching Shear Check calculates Vc incorrectly for deep slabs.‬

‭●‬ ‭The tolerance that is checked for determining the design actions for punching shear at stacked‬
‭columns was increased to avoid conservative design and incorrect values being used.‬

‭Reporting/Results‬
‭●‬ ‭For inclusion of P-Delta combination consideration, the program graphically reports drift and‬

‭moment amplification factors (2nd/1st order results) for local axes, RR and SS, as well as the‬
‭combined global results. The program code checks against a user-defined value set in the Result‬
‭Browser.‬

‭●‬ ‭New XLS reporting is available for lateral drift for P-Delta and non-P-Delta combinations. New reports‬
‭include a list of vertical stations arranged top-down with column coordinates and elevation,‬
‭X/Y/Global displacements at top and bottom of columns, drift at columns with code check,‬
‭maximum drift data arranged for easy plot, average story drift, and story drift plot data.‬

‭●‬ ‭The program now produces a FELT 3D Report – a compiled PDF report summarizing tendon loss‬
‭calculations including graphical views of the tendons horizontal and vertical profile and the loss‬
‭diagrams.‬

‭●‬ ‭Result Display Settings (red eyeglasses) includes graphical reporting options for design sections to‬
‭include the area of steel for provided, required and base (user-defined) reinforcement as well as the‬
‭area of steel/section area (rho).‬

‭●‬ ‭An issue was resolved where the units were not updating properly when KPa and kN/m2 were‬
‭selected in Result Display Settings-Settings.‬

‭●‬ ‭An improvement was made to support the graphical display of the model and results and associated‬
‭result dialog windows when dual monitor setups are used.‬

‭●‬ ‭When in MAT mode and the option for graphical display of Soil Pressure is selected from Result‬
‭Display Settings-Analysis-Slab-Stress, when right-click is used to select the filter, a new warning is‬
‭given "Filter is not available for this item."‬

‭●‬ ‭An issue was fixed related to the crashing of the Report Compiler when screenshots were taken and‬
‭selected and Print or Print Preview was used from the FILE drop-down.‬

‭Graphics/UI‬
‭●‬ ‭A new cloning feature has been added to clone multiple combinations in a single instance and/or to‬
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‭clone combinations as P-Delta types.‬
‭●‬ ‭The selection for display of required and provided rebar on support lines was removed from‬

‭Rebar-Display Manager. Users can obtain this information using new graphical options from Result‬
‭Display Settings (red eyeglasses)-Analysis-Design SectionsReinforcement (Longitudinal).‬

‭●‬ ‭The default design code when launching the program in US or MKS units is set to ACI 318-14.‬
‭●‬ ‭New right-click options for Show Selection, Hide Selection, and Show All have been added when‬

‭selecting at least one component and clicking off the component.‬
‭●‬ ‭Improvements have been made to visibility options found in Floor Design-Strip Results/Visibility. The‬

‭last-selected strip direction X or Y will be retained if the strips are deleted and regenerated and at‬
‭least one support line is displayed. Otherwise, the default X-direction will be displayed.‬

‭●‬ ‭The tendon area defined in the Tendon Properties dialog now supports 3-digit values.‬
‭●‬ ‭An improvement was made for applying curvature color coding to fillet tendons. This option is found‬

‭in Tendon-Display Manager.‬
‭●‬ ‭Two checkboxes were added from Modify-Modify Selection-Tendon-Display Control Points. The first‬

‭checkbox indicates a setting is to be changed and the second is used to display the points.‬
‭●‬ ‭The inactive pull-down options for system type were removed in the Tendon Properties Dialogue.‬
‭●‬ ‭The default values and selections in the Tendon Properties Dialog and Modify-Modify‬

‭Selection-Tendon are now synchronized to display the same values.‬
‭●‬ ‭An improvement to display the total effective force of a tendon when selected from Tendon-Display‬

‭Manager-Stressing-Effective Force.‬
‭●‬ ‭An improvement was made to reinforcement being centered over supports correctly when the option‬

‭is selected from Criteria-Rebar Lengths or Rebar-Rebar Lengths.‬
‭●‬ ‭The Snap Tool Palette was added to the end of the Home ribbon.‬
‭●‬ ‭An issue was corrected where if Tendon-Display Manager was selected all tendons would be‬

‭displayed even if not displayed prior to invoking the dialog.‬
‭●‬ ‭An improvement was made to the Fixed Range contour results so that the values of the contour map‬

‭match the scale values.‬
‭●‬ ‭Loading dimensions properly show assigned loads for all directions when graphically viewed.‬

‭Integration‬
‭●‬ ‭An issue was resolved that was related to crashing when tendons were exported as a DWG file.‬
‭●‬ ‭An improvement was made to import of tendons from ADAPT-PT/RC to Builder when the latest‬

‭versions are used.‬
‭●‬ ‭A correction was made to the .INP file format so that beam dimensions are written as beam width x‬

‭depth.‬

‭Version 2018.3 Enhancements/Corrections‬
‭Reporting/Results‬

‭●‬ ‭An improvement was made to the total effective force to be displayed when selected from‬
‭Tendon>Display Manager.‬

‭Graphics/UI‬
‭●‬ ‭An issue was resolved where the reduced stiffness ratios for cracked deflection combinations were‬

‭not being displayed when selected.‬
‭●‬ ‭An issue was resolved where the program was crashing when selecting a load combination from the‬

‭"Loads" tab in Result Display Settings while the "Analysis" tab was completely expanded.‬
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‭●‬ ‭An issue was resolved in Tendon Optimizer related to the precompression not updating when the‬
‭tributary width was modified in "Settings."‬

‭●‬ ‭An improvement was made to the Home Ribbon by adding a Snap Tools panel allowing shortcut‬
‭keys to be assigned to snap tools.‬

‭Version 2018.2 Enhancements/Corrections‬
‭Modeling‬

‭●‬ ‭An improvement was made to tributary regions being updated when a column endpoint is modified‬
‭from the column properties location input window.‬

‭●‬ ‭An issue was resolved where renaming the default concrete material property corrupts the model‬
‭resulting in program instability during analysis and/or design of sections.‬

‭Reporting/Results‬
‭●‬ ‭An issue was resolved where HTML column design reports was inactive from‬

‭Reports>Columns>HTML>Column Design Summary and Column Design>Reports>HTML>Column‬
‭Design Summary.‬

‭●‬ ‭An issue was resolved where cracked long-term deflection results were not included in the‬
‭Loads>Load Combos>Long-Term Deflections list from Analysis>Result Display Settings (results‬
‭browser).‬

‭●‬ ‭An improvement was made to include long-term deflection combinations for graphically reporting‬
‭the deformation on support lines.‬

‭Version 2018.1 Enhancements/Corrections‬
‭Analysis‬

‭●‬ ‭An improvement was made where imported building load case reactions for Wind and Seismic from‬
‭Etabs were not handled correctly in Analysis->Analysis Options. These reactions should not be listed‬
‭as selectable reactions for 'Include reactions' when they are imported via .INP for 'Reactions only.'‬

‭●‬ ‭A fix was implemented where Builder will crash when the default 'Concrete 1' material property is‬
‭renamed or removed from a model.‬

‭●‬ ‭Save as version 2012 from the File menu was fixed.‬
‭Modeling‬

‭●‬ ‭An issue was resolved where the program was crashing when modifications to a tendon anchored at‬
‭opening edges was made.‬

‭●‬ ‭A correction was for tendons being redrawn and attached to slab edges after the tendon end was‬
‭moved from slab to opening edge.‬

‭●‬ ‭The default modeling mode for tendons was set to linear (straight) versus spline in the Tendon‬
‭properties dialog.‬

‭●‬ ‭The Dynamic Tendon Editor was improved and reorganized to stabilize tendon mode‬
‭and trim functionality and additional options were added. These include:‬

‭○‬ ‭Tendon trim with tolerance setting‬
‭○‬ ‭CGS (same as previous version)‬
‭○‬ ‭Force: number of strands or effective force entry‬
‭○‬ ‭Mode: spline or straight line‬
‭○‬ ‭Anchors (same as previous version)‬
‭○‬ ‭Shape: tendon end span shape as cantilever or straight‬



‭Release Notes‬

‭●‬ ‭Tendon trim/extend was improved to extend/trim only those tendons not snapped to a slab edge or‬
‭opening and to trim/extend to the nearest slab edge.‬

‭●‬ ‭An improvement was made to suppress the green spline curve when moving a tendon set to‬
‭straight/linear mode.‬

‭●‬ ‭A fix was made to the deletion of pattern loads when the 'Save As' function was used.‬
‭Design‬

‭●‬ ‭An improvement was made to the unity convergence for moment capacity of design sections such‬
‭that the demand/capacity ratio is always approached from less than 1.00. This was meant to avoid‬
‭convergence fluctuations caused by a two-sided approach to DCR of 1.00.‬

‭●‬ ‭A new feature was added to allow cracked deflection to be checked using the 'Investigate Sections'‬
‭option rather than reliance on use of the 'Design Sections' option. This allows cracked deflection to‬
‭be performed without manipulation of analysis/design option tags for load combinations or‬
‭suppression of calculation of minimum reinforcement for a model.‬

‭●‬ ‭A correction was made to the default two-way shear strength reduction factor from 0.85 to 0.75.‬
‭Reporting/Results‬

‭●‬ ‭A new feature was added to check balanced loading relative to the sum of average uplift for tendons‬
‭intersecting design sections less than a user-defined angle from support line to section. This allows‬
‭users to check balanced loading with respect to tendons in the same direction as the support line‬
‭with no contribution from tendons in another direction.‬

‭●‬ ‭An improvement was made to display column force and moment diagrams in the proper direction‬
‭and about the proper axis.‬

‭●‬ ‭A refinement was made to the graphical and tabular reported length of reinforcement. When the‬
‭outcome of bar length rounding is 12" the bar length increments by 1 ft.‬

‭●‬ ‭New graphical display options for punching shear design were added to 'Result Display Settings'.‬
‭(Item 6681) These include:‬

‭○‬ ‭Stress check (NA, Reinforce, Exceeds Code, OK) color coding‬
‭○‬ ‭Stress ratios rr and ss directions or combined‬
‭○‬ ‭Condition (end/edge, interior, or corner) including dashed indication of the critical section‬

‭shape‬
‭○‬ ‭Graphical reinforcement and rail summary‬

‭●‬ ‭New graphical display options for punching shear reinforcement were added to 'Result Display‬
‭Settings'. The graphical summary notation includes:‬

‭○‬ ‭Total number of rails‬
‭○‬ ‭Rails along the rr direction‬
‭○‬ ‭Rails along the ss direction‬
‭○‬ ‭Total number of studs on each rail @ spacing (in or mm)‬
‭○‬ ‭Total rail length (in or mm)‬

‭●‬ ‭A new feature was made to the 'Result Display Settings' to graphically report results for manual‬
‭design cuts. These include:‬

‭○‬ ‭Z-translation with span/deflection ratio‬
‭○‬ ‭Section actions: Bending, axial, shear, torsion, and contour cut used for action distribution‬

‭over a contour result from slab results.‬
‭○‬ ‭Stresses including top and bottom fiber stress and precompression‬
‭○‬ ‭Investigation: Moment Capacity and Demand values with demand/capacity ratios‬
‭○‬ ‭Contribution of moment capacity by prestressing‬
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‭○‬ ‭Design criteria‬
‭●‬ ‭A new and improved dockable 'Result Display Settings' (red eyeglasses icon) browser is included‬

‭with updated functionality, grid layout, expandable and collapsing quick tools, setting retention, and‬
‭icons for setting recognition.‬

‭●‬ ‭Graphical reporting of crack widths was added to 'Result Display Settings' in Slab Actions.‬
‭●‬ ‭The punching shear tabular report (Reports->Punching Shear->RTF Reports->Punching Shear‬

‭Reinforcement) now includes the envelope of all Strength combination output.‬
‭●‬ ‭The Tributary Load Check report contains the Cumulative Load Error% comparing applied to‬

‭cumulative loads. This report was corrected to properly account for the sign.‬
‭●‬ ‭An improvement was made to allow the PDF Graphical Report selection to open from Reports->Open‬

‭Report Compiler->File->Generate Compiled Report->PDF Graphical Report.‬
‭●‬ ‭A new XLS report was included from Reports->Punching Shear that reports all critical sections‬

‭checked for columns. Separate sheets included are:‬
‭○‬ ‭Critical section geometry‬
‭○‬ ‭Stress check‬
‭○‬ ‭As required‬
‭○‬ ‭Stud rails‬
‭○‬ ‭Required vs. Provided‬

‭●‬ ‭A new feature was added to include min/max filtering for any slab contour or wall contour result by‬
‭selecting the result option in the 'Result Display Settings' and right clicking to set the filter range.‬

‭●‬ ‭An improvement was made to retain and save title block information from the File menu.‬
‭●‬ ‭A Buildersum issue was corrected where .SUI file headers were missing causing crashing in Builder‬

‭when Buildersum was invoked.‬
‭Graphics/UI‬

‭●‬ ‭An improvement was made to show more than a single digit for gridline tags.‬
‭●‬ ‭Warp increase now functions properly for model warping of global translation (show/hide 3D warp)‬

‭from Visibility->Render Model.‬
‭●‬ ‭The program was modified to allow and store keyboard shortcuts. Customization of the ribbon was‬

‭removed since these functions are hard-coded currently to the program entry state.‬
‭●‬ ‭Spelling correction to 'Visicon' was made in the File->Export window.‬
‭●‬ ‭An issue was resolved where opening Layer Settings from the Home menu was crashing Builder.‬
‭●‬ ‭A correction was made when opening Buildersum from Support Line properties or from the 'Floor‬

‭Design' ribbon resulted in a series of errors/warnings.‬
‭●‬ ‭An issue was corrected related to the option of centering bars over supports from Rebar->Rebar‬

‭Lengths.‬
‭●‬ ‭An improvement was made to retain default tendon colors as set in Visibility->Color Palette when the‬

‭background color is changed.‬
‭●‬ ‭A correction was made to the program crashing when the Undo/Redo functions were selected more‬

‭times than could be completed.‬
‭●‬ ‭Improvements were made to the default colors from Visibility->Color Palette for support line, line‬

‭support and area support. A rebar entry duplication was removed.‬
‭●‬ ‭The graphical scale was improved to include frequency and period for vibration modes.‬
‭●‬ ‭The scale for Investigation options from the 'Result Display Settings' sub-tree was corrected to show‬

‭the proper values.‬
‭●‬ ‭A correction was made to the operability of the tendon intersection detector.‬
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‭●‬ ‭An improvement was made to the Loading ribbon to include new visibility options for loading 'View‬
‭Settings' and graphical loading reports.‬

‭●‬ ‭An improvement was made to the graphical display of beam actions to correlate to the proper‬
‭direction of bending and not the projected plane. For bending about the local ss beam axis, the‬
‭diagram is displayed in the XZ plane. For bending about the local zz axis the diagram is displayed in‬
‭the XY plane.‬

‭Integration‬
‭●‬ ‭An improvement was made to import correct beam data to Builder from INP files generated from the‬

‭Integration Console.‬
‭●‬ ‭A change was made to tendon comments in the .INP file data for effective and calculated force.‬
‭●‬ ‭A change was made to the units for Hagg material factor in the .INP file data so that mm is used and‬

‭converted to US and MKS from base metric.‬
‭●‬ ‭Units for tendon auto-swerve straight length in the .INP file data was corrected.‬
‭●‬ ‭A correction was made to the tendon system description note in the .INP data.‬
‭●‬ ‭A correction was made for imported reactions from Etabs through .INP format that were not‬

‭displayed correctly when selecting another imported load case.‬
‭●‬ ‭A fix was made related to the concrete beam section ID parameter setting for beam exported from‬

‭Integration Console through .INP file format.‬
‭●‬ ‭A spelling error was corrected in the .INP file in the tendon data block.‬

‭Version 2018.0 Enhancements/Corrections‬
‭Analysis‬

‭●‬ ‭New design codes were added to the program: Australian AS3600-2009 and Hong Kong CoP 2013.‬
‭●‬ ‭Meshing options have been consolidated and new options are available for applying an advanced‬

‭meshing algorithm for meshing of walls with or without openings. The simplified meshing option is‬
‭similar to previous versions and will disregard wall openings by default.‬

‭●‬ ‭For slabs-on-grade, mat slabs and slabs-on-piles with steel fiber, the selection for nonlinear behavior‬
‭can be used for consideration of post-elastic capacity for flexural behavior.‬

‭●‬ ‭For slab-on-grade designs with steel fiber, the program calculates joint spacing requirements and‬
‭load transfer factors across joints for edge and corner zones of a slab panel.‬

‭●‬ ‭An issue was corrected where the program was creating a redundant entry in the input file to‬
‭frame.exe for building loads created by use of the Lateral Load Wizard.‬

‭●‬ ‭A load combination indexing issue was fixed where incorrect stress diagrams appeared when‬
‭CRACKED DEFLECTION combinations were run with combinations of other analysis/design option‬
‭types necessary for checking concrete stresses.‬

‭Modeling‬
‭●‬ ‭Walls can now be modeled with openings in a simple-to-use input window embedded in the wall‬

‭properties. The user enters the opening start coordinates and the length and width of the wall‬
‭opening. Multiple wall openings can be added to walls.‬

‭●‬ ‭Steel fibers can now be modeled as part of a defined concrete material property. Multiple fiber types‬
‭are available with dosage ranges for selection. Steel fibers can be applied to slabs-on-grade, mat‬
‭slabs, slabs-on-piles and elevated slabs and are considered for calculation of minimum‬
‭reinforcement, one- and two-way shear and flexure.‬

‭●‬ ‭Improvements were made to slab modeling by coordinate commands CANCEL and UNDO.‬
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‭●‬ ‭Models created prior to v2018 that include default beam rebar that are opened in v2018 will have the‬
‭beam rebar removed. This function for beam rebar is no longer included in the program. User should‬
‭create beam rebar using REBAR>Base>Banded.‬

‭Design‬
‭●‬ ‭For slenderness check of walls in the Wall Designer, a modification was made to properly convert the‬

‭external units of the variable "Lu/16." The converted units will be [in],[mm],[cm] the same as wall‬
‭thickness units. Previously the wall height was always taken in [in].‬

‭●‬ ‭The max. spacing for one-way shear reinforcement was modified from 300mm to 600mm per EC2.‬
‭●‬ ‭For EC2, the program now includes a check to ensure reinforcement is provided to meet 1.15*Mcr‬

‭for unbonded, PT beams. This complies with requirements in Section 9.2.1.1- 4 of the EC2 code.‬
‭●‬ ‭The program is now in sync and includes all codes as permitted by S-Concrete for column design.‬

‭The codes are set from COLUMN DESIGN>Settings>Design Settings.‬
‭Reporting/Results‬

‭●‬ ‭A correction was made where reporting of graphical wall or column reactions were always opening‬
‭the column reactions dialog.‬

‭●‬ ‭Wall zone bar length and bar fit status are reported as OK or NG in the wall design section summary‬
‭report for improved correlation with the design summary at the top of the report.‬

‭●‬ ‭The slenderness check status is no longer highlighted within the slenderness block of the wall‬
‭design summary report.‬

‭●‬ ‭The bar spacing check was removed from the zone confinement block in the wall design summary‬
‭report.‬

‭Graphics/UI‬
‭●‬ ‭The program user interface has been completely overhauled with an updated program user interface‬

‭(UI) for improving the user experience and offering an easy-to-use, efficient and intuitive program‬
‭environment. The UI is now ribbon based containing contextualized ribbons including general‬
‭categories like visibility, modeling, analysis, design and reporting. Each ribbon contains‬
‭ribbon-specific tool panels with updated, refreshed icons. New summarized and extended tool tips‬
‭have been included for each tool and tool panel.‬

‭●‬ ‭The program has a new simplified and condensed splash screen with an expandable selection‬
‭window. The splash screen shows the current program state.‬

‭●‬ ‭The program now auto-filters the available tools that apply to the splash screen selections made by‬
‭the user prior to entering the UI. Only ribbons, panels and tools applicable to the state will be shown‬
‭to streamline usage. Ribbons, panels and tools not applicable to the current modeling, meshing,‬
‭analysis, design or level state will be grayed out and inactive.‬

‭●‬ ‭Walls can now be modeled with openings in a simple-to-use input window embedded in the wall‬
‭properties. The user enters the opening start coordinates and the length and width of the wall‬
‭opening. Multiple wall openings can be added to walls.‬

‭●‬ ‭The option for "Save as Default" was removed from the FILE menu.‬
‭●‬ ‭The load combination names are now checked for compatibility with allowed characters including:‬

‭○‬ ‭numbers‬
‭○‬ ‭letters‬
‭○‬ ‭brackets []‬
‭○‬ ‭parentheses ()‬
‭○‬ ‭spaces‬
‭○‬ ‭underscore _‬
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‭All other characters are not allowed.‬
‭●‬ ‭An issue was fixed where the loading font and symbol size entries were resetting to zero in the‬

‭select/set view items (blue eyeglasses) window.‬
‭●‬ ‭In the Tendon Display Options when the total force is selected to be displayed for decimal the‬

‭program uses actual decimal number rather than the strand integer.‬
‭●‬ ‭The drop-down list of load combinations in 'Render Model' (teapot tool) is now available only for‬

‭when deflection tools in the Solid Modeling UI are active.‬
‭●‬ ‭An improvement was made to return the state of a model back to the HOME ribbon and screen after‬

‭importing a file from FILE>INP.‬
‭●‬ ‭If a combination that includes Hyperstatic is selected for a deflection display (warped or deformed‬

‭shape view) in the 'Render Model' tool, the following message will be shown: “This combination‬
‭includes the Hyperstatic load case. When solved analytically, due to self-balanced loads and to‬
‭reduce rigid body motion, special support conditions are used. The displacements for combinations‬
‭including the Hyperstatic load case will appear as a cantilevered system and should not be used in‬
‭evaluating displacements. If the effects of post-tensioning are to be considered for displacements,‬
‭review combinations that are set to the "Service" analysis type and ensure that the PT load case is‬
‭used. This considers both primary and secondary effects of PT.”‬

‭●‬ ‭An improvement was made to the punching shear status incorrectly showing "Reinforce" rather than‬
‭"Exceeds Code."‬

‭●‬ ‭An improvement was made to allow the user to navigate and set the S-Concrete executable path for‬
‭updated versions of that program necessary for column design integration with Builder. The new‬
‭option is located in the COLUMN DESIGN ribbon.‬

‭●‬ ‭An improvement was made to display the graphical representation of supports after creation of‬
‭supports from the MODEL>Supports panel.‬

‭●‬ ‭An improvement was made to add tools on the COLUMN DESIGN and WALL DESIGN ribbons that‬
‭isolates all columns or walls in Single- or Multi-level view.‬

‭Integration‬
‭●‬ ‭New ADAPT-Revit 2019 and updated ADAPT-Revit 2018 Integration Links were created for‬

‭compatibility between ADAPT-Builder 2019 and Revit 2018. Features included are:‬
‭○‬ ‭Import geometry to ADAPT‬
‭○‬ ‭Import applied loads to ADAPT‬
‭○‬ ‭Import load combinations to ADAPT‬
‭○‬ ‭Export geometry and gravity load to Revit‬
‭○‬ ‭Export reinforcement and post-tensioning to Revit‬

‭●‬ ‭An issue was corrected where reinforcement written to .INP file at a single level was‬ ‭being imported‬
‭back to all levels of a multi-story model and vice versa.‬

‭●‬ ‭A correction was made to properly import column and wall reactions from a .INP file to version 2018.‬
‭●‬ ‭A correction was made to the tendon area written to the .INP file that was incorrect.‬
‭●‬ ‭An issue was fixed for the Etabs Integration Console where import of a single level was not writing‬

‭the correct level data to the .INP file.‬

‭Version 2017.3 Enhancements/Corrections‬
‭Modeling‬

‭●‬ ‭A new feature was added for the modeling of Bekaert Dramix steel fiber material. The program‬
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‭includes the option for modeling concrete material with the presence of steel fiber. Fiber type and‬
‭dosage can be assigned to a system type of Elevated, Mat, Slab-on pile, and slab-on-grade.‬
‭Modifications to one-way shear, two-way shear, and flexural capacity now consider the presence of‬
‭fiber when modeled. The program includes an option for designing a slab-on-grade, slab-on-pile or‬
‭mat slab with non-linear effects when fiber material is assigned to the system.‬

‭Design‬
‭●‬ ‭A new feature was added for the calculation of a joint load transfer factor for point, line, and patch‬

‭loads modeled on a slab-on-grade design when the slab is set to a fiber material property.‬

‭Version 2017.2 Enhancements/Corrections‬
‭Analysis‬

‭●‬ ‭A correction was made to the load type Seismic - Applied Loads" was incorrectly being flagged as‬
‭"Special Lateral."‬

‭●‬ ‭Improvements were made to the discretization of patch loads such that they are being fully resolved‬
‭in equilibrium with reactions. This occurs where point or line loads are discretized over course‬
‭arrangement of shell elements.‬

‭Modeling‬
‭●‬ ‭An issue was corrected where Builder crashed when a new tendon was added that had the option for‬

‭straight span-spline override selected in the tendon properties menu was retained upon re-opening‬
‭the model.‬

‭Design‬
‭●‬ ‭An issue was corrected where Designer.exe and Punshear.exe crash when an imported .INP file‬

‭contains the duplicate concrete material name CONCRETE 1.‬
‭Reporting/Results‬

‭●‬ ‭An improvement was made that now includes the tributary loads in the Column Design XLS report‬
‭when this option is used for column design.‬

‭Integration‬
‭●‬ ‭A correction was made where variable area loads were not imported correctly from the .INP format.‬
‭●‬ ‭An issue was corrected for improper units of area load moments imported from the .INP format.‬
‭●‬ ‭A correct was made to the assignment of the generic material property to imported components‬

‭from the .INP format.‬
‭●‬ ‭An improvement was made to stabilize Builder when exporting a slab located outside of the slab‬

‭region using the .INP format.‬
‭●‬ ‭An issue was corrected for applied lateral story forces being properly written to the Lateral Loading‬

‭generic tabular input dialogue when importing from .INP format.‬
‭●‬ ‭An issue was corrected that allows for inclined columns with non-zero X and Y offsets to be‬

‭imported from the .INP format.‬
‭●‬ ‭The .INP import format was improved to merge slabs based on both similar thickness and material‬

‭assignment for imported slab regions.‬
‭●‬ ‭Column labeling when exporting from .INP was modified to match the unique Builder ID sequentially.‬
‭●‬ ‭Component reactions, releases and stiffness modifiers written to the .INP format were modified to‬

‭be mapped using GUID's.‬
‭●‬ ‭An issue was corrected where load case reactions were being duplicated in the .INP file for each‬

‭analysis run made prior to exporting the data.‬
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‭●‬ ‭The load type "Standard" was included in the Import Options dialogue when importing general load‬
‭cases using the .INP format.‬

‭●‬ ‭A correction was made for import of load combinations from the .INP format where all combinations‬
‭were only available to import and not a partially selected group.‬

‭Version 2017.1 Enhancements/Corrections‬
‭Design‬

‭●‬ ‭An issue was corrected where the sign for axial loads generated from the tributary load takedown‬
‭tool to be taken as the opposite in the .SCO file for column design.‬

‭●‬ ‭An improvement was made to the minimum reinforcement requirements for sections cutting over‬
‭walls was greater than that required by code.‬

‭●‬ ‭A column design parameter name for optimization constraint 'B' dimension was not mapped‬
‭properly to the .SCO file.‬

‭●‬ ‭Tendon Optimizer was stabilized so that the current stress was not updating causing the Optimizer‬
‭to loop in solving for the estimated force.‬

‭●‬ ‭An improvement was made in ADAPT-MAT that allows the user to calculate required minimum‬
‭reinforcement in addition to reinforcement for Strength.‬

‭Reporting/Results‬
‭●‬ ‭An issue was corrected where the number of strands were not being displayed when generating‬

‭chair heights.‬
‭Graphics/UI‬

‭●‬ ‭Selecting multiple entities using CTRL + click or window was improved so that the currently selected‬
‭components were not de-selected when CTRL was used.‬

‭●‬ ‭An issue related to crashing when a concrete material assignment was renamed was fixed.‬
‭●‬ ‭An issue related to import of generic sections was fixed.‬

‭Integration‬
‭●‬ ‭An improvement was made in Builder that was related to the option for importing applied loads from‬

‭the .INP Import Options to be blank.‬
‭●‬ ‭An issue was corrected where only one opening was imported for files containing multiple openings‬

‭when imported using INP format.‬
‭●‬ ‭An issue was fixed where components were not imported with a unique ID.‬
‭●‬ ‭An issue was fixed related to unassigned tendon material properties when importing tendons using‬

‭INP format.‬
‭●‬ ‭An issue related to import of variable area loads was fixed.‬

‭Version 2017.0 Enhancements/Corrections‬
‭Analysis‬

‭●‬ ‭An issue was corrected where Builder was crashing when analyzing models containing lateral loads‬
‭assigned using the Lateral Load Wizard or imported, due to incorrect indexing of nodes in the INP‬
‭file.‬

‭●‬ ‭An improvement was made to properly incorporate global gravity reactions when selected in‬
‭single-level mode when in ADAPT-MAT.‬

‭●‬ ‭An improvement was made to properly include load takedown forces initiated from‬
‭Loading>Tributary Loads, in a single-level punching shear check, when re-analyzing a single-level‬
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‭with inclusion of tributary reactions using the Load Takedown option.‬
‭●‬ ‭ADAPT-MAT and SOG were modified to allow for “Compression only” soil supports.‬

‭Modeling‬
‭●‬ ‭Improvements were made to more accurately and rapidly model tendons and make modifications to‬

‭tendons. These include:‬
‭○‬ ‭Tendon modeling as splines with accurate in-plane curvature versus linear segment‬

‭representation.‬
‭○‬ ‭Improved accuracy in tendon losses and elongation calculations when "Calculated Tendon‬

‭Force" option is used.‬
‭○‬ ‭In-plane tendon swerving using swerve points. Three swerve points can be modeled in any‬

‭tendon span. Automatic swerve points are added to tendon ends as a default.‬
‭○‬ ‭Adding and deleted tendon spans with easy insertion of control points by right-click options‬

‭or new insertion point tools.‬
‭○‬ ‭Tendon anchorage – Fixed or free tendon anchorage options allowing for tendons to lock to‬

‭slab edges.‬
‭○‬ ‭Centralized and easy-to-access Tendon Display Manager from the Tendon Toolbar.‬
‭○‬ ‭Tendon display option toggle for strand round-up or decimal input.‬
‭○‬ ‭Tendon force display for effective, average, max or min force.‬
‭○‬ ‭Tendon display options for control points, swerve points, and inflection points.‬
‭○‬ ‭Improved layer control for export of tendon information to DWG and DWF formats.‬

‭●‬ ‭With tendons modeled using the new curved, spline representation, the program color codes tendons‬
‭for different zones of curvature relating to the requirement of “hairpins” or bursting reinforcement.‬

‭●‬ ‭An issue was corrected where if a column or wall stack didn't have a slab above the component, the‬
‭cumulative load for tributary load takedown was zero and the self weight of these components at‬
‭the level where the slab is missing was not considered for reported loads in the levels below.‬

‭●‬ ‭The “Mapped Banded Tendons” tool was improved to allow the user to define the shape of the first‬
‭and last span, in addition to the middle span.‬

‭●‬ ‭An issue related to the CGS reference plane when using the “Extended Reversed Parabola” profile‬
‭was corrected.‬

‭●‬ ‭An instability that caused the number of design sections to be reset to ‘1’ was corrected.‬
‭●‬ ‭An instability in the program when transforming polygons into walls was corrected.‬
‭●‬ ‭An issue causing the program to crash when a support line vertex is deleted was fixed.‬
‭●‬ ‭An issue related to the incorrect stiffness of line spring when defined in MKS units was corrected.‬
‭●‬ ‭A modification was made to create design sections 2”, by default, from faces of columns, beams or‬

‭drop caps.‬
‭●‬ ‭A modification was made related to the creation of incorrect geometry when using the “Beam/Frame‬

‭Wizard” was corrected.‬
‭●‬ ‭The “Line Load Wizard” was improved to prompt the user to select graphical entities for line load‬

‭placement.‬
‭Performance‬

‭●‬ ‭A multi-core algorithm was implemented for analysis preprocessing.‬
‭●‬ ‭The processing speed for “Generate Design Sections Automatically” has been improved.‬
‭●‬ ‭The 3D Viewer was made faster to display models with numerous tendons.‬
‭●‬ ‭The option to abort the “Import DWG/DXF” operation through use of the “Esc” button has been‬

‭implemented.‬
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‭Design‬
‭●‬ ‭The Canadian Standard, CSA A23.3-2014, was implemented.‬
‭●‬ ‭The program now includes an integrated tendon design optimizer that allows the user to optimize‬

‭selected groups of tendons for serviceability requirements –precompression, allowable tension and‬
‭compression stress and balanced loading. Solutions provided by the optimizer allow for on-demand‬
‭updating of the structural model by adding tendons or modifying the selected tendons to be‬
‭optimized. The optimizer includes dialogue windows for user interaction and on-demand feedback.‬
‭An edit mode allows users to override program-optimized forces and number of strands for custom‬
‭checks of selected slab regions. The program includes on-screen and exportable text output for‬
‭calculations for a given optimization instance.‬

‭●‬ ‭A new feature includes the ability to design concrete shear walls, with or without boundary elements‬
‭for seismic lateral resisting systems. The program includes a native ADAPT Wall Designer and‬
‭integration with S-Concrete’s wall design program. Walls are grouped into piers for the purpose of‬
‭generating wall design sections. A Wall Manager stores section information such as geometry,‬
‭reinforcement, material, etc. Single or multiple design sections can be processed for design or code‬
‭check. The program produces both graphical and tabular output for wall code checks, interaction‬
‭diagrams, utilization checks and wall intersection zones where reinforcement congestion is of‬
‭concern.‬

‭●‬ ‭An option to exclude minimum spacing requirement for RC structures has been added.‬
‭●‬ ‭An issue related to the calculation of design section actions for pattern loading envelopes was‬

‭corrected.‬
‭●‬ ‭An issue related to the incorrect units being reported for “Jacking Force” in the “Tendon Elongation‬

‭Report” was corrected.‬
‭●‬ ‭An issue related to the generation of input data for the “Friction and Elongation” module was‬

‭corrected.‬
‭●‬ ‭A modification was made to the stress data of the “Prestressing” block of the DSI file so that when a‬

‭design section cuts through a tendon, the prestress is reported.‬
‭●‬ ‭The calculation of one-way shear reinforcement was corrected for the BS code.‬

‭Reporting/Results‬
‭●‬ ‭A new option for display of analytical, discretized tendon segments is now made available in the‬

‭Tendon Display Manager. After meshing and analyzing the model, the user can use this option to‬
‭view tendon segments.‬

‭●‬ ‭Colorization has been added as a new Result Display Settings category for graphical results. This‬
‭allows the user to easily determine identical wall design properties and characteristics in complex‬
‭models. Colorization can be applied to wall thickness, material, pier labels and reinforcement in‬
‭zones and panels.‬

‭●‬ ‭Walls can now be grouped into piers for determination of combined wall pier reactions. Reactions‬
‭and pier geometry can be reported graphically and in tabular format.‬

‭●‬ ‭An improvement was made for graphical reporting of load takedown forces. The program now‬
‭displays the cumulative loads in the form of axial force diagrams when using Load Case results from‬
‭Result Display Settings (red eyeglasses).‬

‭●‬ ‭A problem was fixed where the axial force diagram for beams contained the wrong sign. The fix‬
‭includes proper sign of (-) for compression and (+) for tension.‬

‭●‬ ‭Point and Line Spring Reactions reports have been added to Tabular Reports.‬
‭●‬ ‭An issue related to the incorrect stress calculation for design sections that cut walls was fixed.‬
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‭●‬ ‭An issue related to the incorrect initial stress calculation for the 1994 and 2004 Canadian Codes was‬
‭corrected.‬

‭●‬ ‭An issue related to the incorrect reported rebar length when the option, “Adjust length and center top‬
‭bars over supports,” is used, was corrected.‬

‭●‬ ‭A problem that caused a discrepancy in rebar results between Buildersum and the graphical beam‬
‭elevation was fixed.‬

‭●‬ ‭An issue related to the incorrect quantity of beam corner bars shown in the support line elevation‬
‭view was fixed.‬

‭●‬ ‭An issue related to the tabular report not displaying enveloped shear reinforcing and spacing was‬
‭fixed.‬

‭●‬ ‭The reporting of a deflection ratio was corrected for manual design sections.‬
‭Graphics/UI‬

‭●‬ ‭A fix was implemented that saves user-defined live load reduction input from Loading>Live Load‬
‭Reduction so that it does not need to be re-entered each time the model is opened.‬

‭●‬ ‭The item display features of ADAPT-Builder have been improved, including “Select/Set View Items”,‬
‭“Layer Settings” and individual component display tools.‬

‭●‬ ‭The “Generic ADAPT File” import feature located in the “File” pull-down menu, has been improved.‬
‭●‬ ‭The design section length has been included in the “Manual Design Section” dialogue window.‬
‭●‬ ‭The “Load Combination” window was improved to not allow a user to save any cracked load‬

‭combination including the “hyperstatic” load case.‬
‭●‬ ‭The default load factors for the “Initial Load” combination were changed to include‬

‭1.0*SW+1.15*Prestressing.‬
‭●‬ ‭A problem was corrected causing the deletion of the pattern loading envelope when a user selects to‬

‭delete a load case not assigned to any load.‬
‭●‬ ‭An issue causing the program to crash due to the name of a load combination was fixed.‬

‭Integration‬
‭●‬ ‭A new ADAPT-Revit Link 2018 was introduced and is compatible with this version of Builder.‬
‭●‬ ‭The generic exchange file format (.INP) now has the ability to pass tendon data for incorporation in a‬

‭Builder (.ADM) file.‬
‭●‬ ‭An issue was fixed where the program did not properly write applied gravity load case data correctly‬

‭to the INP file in the "Include Lateral" option is selected in single-level mode and selected load‬
‭combinations did not contain lateral load cases.‬

‭●‬ ‭A correction was made related to the incorrect load factor for SDL exported to ADAPTRC from‬
‭Builder was fixed.‬

‭●‬ ‭A correction was made related to the export of Builder models using the ACI 2008 code to ADAPT-PT‬
‭was corrected.‬

‭*Release notes for versions prior to v2017 can be found in the program files at C:\Program Files‬
‭(x86)\ADAPT\ADAPT-Builder 2020\log_builder.text‬


